ギークなエンジニアを目指す男

基幹系SIerがWeb系とかネイティブ系の知識を蓄えようとするブログ

MENU

Rails newコマンドでinstalling nokogiri (1.8.1)エラーが発生したときの対処手順

目次

実行環境

OS:macOS Sierra Ver.10.12.5
Ruby:2.4.1
Rails:5.1.4

エラー

Railsの勉強中に起きたエラー。
rails newコマンドを実行すると下記エラーが。。。
ほぇ、、、なんじゃこりゃ

An error occurred while installing nokogiri (1.8.1), and Bundler cannot continue.
Make sure that `gem install nokogiri -v '1.8.1'` succeeds before bundling.

エラーの通りに

gem install nokogiri -v '1.8.1'

と入力してもダメでした。

解決方法

この解決方法を見つけたため、備忘録として残しておきます。

このQiitaの記事を参考に解決できました。

$ brew update
 :
$ brew install libxml2
 :
$ brew link --force libxml2
$ gem install nokogiri -- --use-system-libraries
 :
$ brew unlink libxml2

ありたがや。
こんなの一人で解決できる気はしない。
開発環境構築で挫折する人が一人でも減ることを祈ります。